What phones support the Outhlook app?

iOS device requirements:

Requires iOS 13.0 and watchOS 6.0 or later. Compatible with iPhone, iPad, and iPod touch.

 

Android Phones system requirements:

Outlook for Android can be installed on any of the supported Android

versions that have an ARM-based or Intel x86 processor. This includes KitKat1 (4.4 - 4.4.4), Lollipop1 (5.0

– 5.1.1), Marshmallow (6.0 – 6.0.1), Nougat (7.0 – 7.1.2), Oreo (8.0 – 8.1), and Pie (9.0)

 

Click to return to MFA homepage.